[Bug] "Failed to save file ... FILE_NOTCREATED."

Platform Android

Obsidian Mobile version: v1.0.4

When I write something in notes - appears message “Failed to save file … FILE_NOTCREATED.”

It appears every time i write something, what can i do with this? I saved obsidian directory in microsd card, maybe that’s the reason why it’s happening, but I give permission to make changes, so I don’t know.

Hope you fix this or tell me how to fix this issue.

You could try …

Open Chrome browser | 3 dot Hamburger menu top right | Settings | below Advanced | Downloads | click on Download location | → click on SD Card ←


After a reboot hopefully Obsidian will now work on your SD Card & still work on your Local drive.

Then later you can revert your “Download location” to your Local drive & Obsidian still should work on your SD Card.

Something similar worked for me on my Android tablet.

PS: If the above doesn’t work you could try removing the SD card & re-inserting after a reboot. Perhaps Obsidian will now recognize your SD card as authorized.

I have the same problem. Android 8.0, Obsidian 1.0.4 cannot write to SD Card. The Chrome hint didn’t help, neither did re-inserting the SD Card.

I also tried these two suggestions and neither one worked. I have confirmed I can write to the SD card by using FX text editor to edit the same file I was trying to edit in Obsidian. I am using Obsidian 1.0.4 and Android 7.0 on a Samsung Galaxy Tab S2.