[Bug] editor randomly jumps around and erases work

Platform

Android
Samsung s20+

Obsidian Mobile version: v1.0.5


bug description

At random times at high rates the editor will suddenly jump to a random location and occasionally erase all text written from a seemingly random point all the way down. but it will not erase in very short files.

It happens even when I create a whole new vault.

It makes the mobile version completely unusable.

reproducing

I dont know how to reproduce the bug. It just started a few days ago, and it’s so frequent I can’t even use the app anymore.

But I can tell that it doesn’t take anything to induce it.

In some of the examples below I didn’t even hold the phone.

Erasing however requires a sufficiently long file.

gifs

Example of jumping and erasing. Phone was not held. New vault without plug-ins.

20211217_040328

Example of jumping in an empty new vault without plugins.

20211216_104320

Examples of jumping to random location while typing.

20211216_014311

20211216_014344

Example of jumping without typing. Jumping with cursor at top if editor. Phone not held.

20211216_013851

2 Likes

I can’t see any erasing in the vault without plugins. I see some jumps from the keyboard going in an out.

The top gif is from a vault without plugins. I just copied a file from another vault into it. And you can clearly see in the gif that the bottom of the page was erased.

It’s not a visual bug, pressing undo returns the deleted part,and I have syncing with a pc that doesn’t have that bug and kf it was erased in the phone it showed in the PC as well.

The keyboard doesn’t go in and out. I even tried replacing a keyboard, but no use.

+1 I’m using Obsidian on iOS (iPad primarily) and I have noticed the jumping around behavior when using the keyboard though mine hasn’t erased any text, yet (:crossed_fingers:t4:).

Also noted here

1 Like

This sounds like the same issue I’m experiencing on my Samsung Tab S7+. The cursor jumps to the very end of the note and will create a new line. It will also randomly delete content as well.

Is there any fix?

I’m having this problem too with my z fold 3. I just updated my phone to the latest android version and only noticed it after that, maybe it can be related. Using version 1.0.5

I tried disabling all the plugins including sync. I noticed that for me it only jumps to the bottom of the note and places a new line. It’s very disrupti e and unpredictable. I don’t have to wait long and starts happening within 5 seconds of interacting with the note.

Anyone maybe have some more information to share about this bug?

The app is unusable at the moment for me. I like the app, and it works well for my current workflow, so if there is anything I can do to help troubleshoot the problem, I’ll help.

I’ve now tried doing a rollback 1.0.4 & 1.0.2 disabling themes, CSS, and all plugins (community and core) however this has not resolved the issue sadly. I have been able to run everything fine until a few days ago, with the major change being the update to Android 12.

Workaround: editing in another app.

Edit: I’ve noticed that switching to and from editing mode helps make the jumps less frequent. Also nothing happens until the first letter that is typed.

I found the problem (for me at least)! It’s the grammarly implementation in my Samsung keyboard. Turned it off and there were no jumps anymore.

I noticed that todoist wasn’t behaving as expected as well sometimes. This tipped me of that it might be my samsung keyboard I’m using. I’m dutch so I also switch the language on my keyboard but grammarly doesn’t support Dutch. If it was on Dutch I had no problems anywhere. This led me to grammarly being the problem as it was new since this update.

(To turn grammarly off for the Samsung keyboard look for the 3rd party menu in the keyboard settings)

Hope this will also fix the problems for the other people here. I don’t have an iPhone but it could be that there is the same sort of whacky imementation of grammarly or some other language feature.

Has this been fixed yet?

It is definitely an issue with the Samsung Keyboard. If I switch to GBoard, it goes away. I switched off every 3rd part app for the Samsung Keyboard and it still occurs.

It appears to be an issue with the Predictive Text part of the Samsung Keyboard. I turned on all of the 3rd part app plugins for the Samsung Keyboard and turned off the Predictive text value in the keyboard settings and the issue stopped.

Using 1.0.5 Android app and Samsung Keyboard version is 5.4.20.10.

I can confirm the same on a Samsung Tab S7+ and Galaxy Note 20U devices. Third party keyboard plugins such as Grammarly are enabled, while Predicitive text is disabled and I no longer experience this issue.

Hopefully this is something that can be corrected in a future update since I rely on the predictive text functionality, particularly for emojies.

I am on iOS and iPadOS and while I haven’t had issues with content being erased, I have experienced the exact same jumping around issue.

Is this issue being looked at? I’d love to be able to use the mobile app on my Samsung Galaxy devices.