[Bug] Can’t access command palette


[ x] iOS
[ ] Android

Obsidian Mobile version: 0.0.19 (6)

I can’t access command palette properly on iPad.
I thought the “undo redo paste” iPad bar was preventing the access to the command palette. I found out how to disable the “undo redo paste” bar, but I still can’t access Obsidian Mobile command palette.
How can I solve this?

1 Like

Another question: how do I know this issue is being analyzed? Is there a list of bugs to fix, similar to the roadmap?
I had a problem with a plugin, earlier. This is my first bug report, so I am a bit lost.

Not sure I understand the issue. A screenshot would definitely help.

Also, if you’re using a custom theme or css snippets, please disable them first and see if they’re the cause of the issue.

1 Like

Thank you, @Licat, for the reply!!! :smile:

I’m going to add a link to a short video. Screenshots can’t capture the issue properly.
Herewith is a link to a video recording the issue.

I was trying to open the command palette using a hotkey in the video, but it didn’t work.

By default, the iPad displays an “undo redo paste” bar at the bottom of the screen. I thought that the “undo redo paste” bar was preventing the display of the command palette bar. So, I disabled the “undo redo paste” bar, as I have previously mentioned, but it didn’t solve the problem.

The video was recorded with that “undo redo paste” bar disabled, and the command palette didn’t open.

I still can’t access the command palette.

I have tried to change the hotkey, as well, but it didn’t work either.

I hope you can solve that problem.

Thank you for taking the time to analyze the issue.

I can only open command palette using the “command” P hotkey, with no file opened.
If there’s a file opened, I get the same bug again.
I’ve tried to:

a) disable iPad copy paste bar;
b) disable Command Palette, close the app, relaunch it and enable command palette;
c) uninstall the app and then reinstall it;
d) change the hotkey;

There’s no custom theme or CSS applied.

Nothing worked.

From your video, it seems like the drag down action is triggering some kind of UI that doesn’t belong to Obsidian? Do you have an idea what that is? I believe this is what interferes with the drag action.


Thats the iPadOS’ system shortcut hint which shows up in any app supporting keyboard shortcuts (much like in Discord/Gmail when pressing ?).

I tested on my side and Obsidian on iPad doesn’t show this hint. BUT this exact hint shows up when I first bring up Spotlight Search (iPadOS’ system level search) by using the shortcut CMD + Space.

What’s interesting is there’s a gesture to bring up spotlight search which is swiping down with one finger in the middle of the screen much like bringing up the command palette in Obsidian. This is definitely a bug since that gesture is supposed to work only on the home screen and not inside any app.

Hi, @Licat! Sorry for the late answer!
With the newest version 0.1.4 (12), the bug disappeared.
I can access the command palette using the hotkey.
Would you like me to record a new video?

I was unable to open command palette using either “the swiping down with one finger method” or the hotkeys in Obsidian.
Curiously, the shortcut CMD + Space was not affected on my iPad.
With the version 0.1.4 (12), the bug disappeared and, both methods (swiping down or pressing hotkeys) are working just fine, with the “swiping down method” being very sensitive: if I am careless, command palette opens all the time! :joy: :joy: :joy:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.