Bookmarks Vanish unless fully zoomed out?

Here is a short video I made showing the exact problem

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

Try the debugging steps.

  • Make sure your Obsidian installer is up to date. If you haven’t downloaded a new installer from the website in a long time, re-download Obsidian from the website and reinstall it.
  • Make sure you update all your plugins and themes, periodically.
  • Test in default theme to see if the problem disappears.
  • Turn off any custom CSS snippets to test if the problem disappears.
  • Test turning off all community plugins to see if it fixes it. Then turn them back on to see which one causes the problem.

Help docs had nothing, My current installer version is 1.1.9, how can I see what the current version from the website is, I looked but don’t see it?

All plugins and themes are updated, I did test in default theme but to no avail.

Have never used any custom CSS Snippets

Just tried your advice about turning off all community plugins, again, to no avail.

So now what?

Download and reinstall Obsidian, post a screen recording of this happening in the sandbox vault. Thanks!

I will gladly do that if I know ahead of time the installer version is indeed in need of an update. Where can I see the current version number, so I do not go through the process of a screen recording and then having to upload it to YouTube because the screen recording file is too large to post in the sandbox bolt. Thank you.

just do the screen recording after you have reinstalled obsidian.
Make sure it’s of the sandbox vault.

Okay I did that, the installer was indeed in need of an update, rebooted everything, i’ve never messed with the sandbox vault before and I just did, seeing that the bookmarks work there, but when I return to my actual vault, all it says now is “Failed to load bookmarks, the data file is corrupted”.

I did not do the screen recording because I am not going to sit here and wait for it to upload to Youtube just for you to know the same information, it is exactly as I describe. It’s the exact same result as the first screen recording I posted in this thread. When I try to make a new bookmark, it gives me the quote above. When I bookmark in the sandbox, yes, I see it in the bookmarks, but when back in the vault that counts, the problem still remains.

You posted a video originally, that showed your bookmarks. So I assume there is no sensitive info in your bookmarks? You could upload your bookmarks.json file so someone could take a look and see if they can spot what went wrong. If that file is actually corrupted.

OR, if you don’t have too many bookmarks and this won’t be too troublesome, you could just delete the bookmarks.json file completely (or safely move it away out of the .obsidian folder), and then rebuild your bookmarks.

If you share it, things I would look for if I was looking in that bookmarks.json file:

  • Are there any syntax errrors in the json.
  • Are there are any suspicious special characters that might be parsing badly.
  • Did the file get corrupted or cut off or something.

Interesting, okay, thank you for your advice here, I will try to delete/move the Json completely and just see if I can simply re add them after the fact.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.