Blockquotes inside comments extend beyond the comment's end in Live Preview mode

Steps to reproduce

Create a markdown comment. Put a blockquote within it. Write something right outside the comment, like this (1):

%%A blockquote inside a comment section.%%
Outside text (not a comment).

or, like this (2):

%%A blockquote inside a comment section.
Outside text (not a comment).

or, like this (3) (I’m sorry about this one; couldn’t resist):

%%A blockquote inside a comment section.
%%Outside text (not a comment).

Expected result

The part outside the comment should be rendered as if no comment exists. As it is rendered in reading mode:

Actual result

Outside text is rendered as a part of the blockquote:


Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: Windows 10 Pro 10.0.19045
Login status: logged in
Catalyst license: insider
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

Additional information

I understand that case (3) can be hard to fix due to the block nature of a blockquote (and a sane person shouldn’t format their stuff like that anyway), but cases 1-2 are legit imo.

I don’t understand you. Can you attach a file where this happens?

Does typing a blank line between either or both not-comment lines and the comment fix the problem? (You shouldn’t have to in this case, but in general it’s best to put blank lines between blocks.)

Someone posted a similar issue recently.

E.g., this. (434 Bytes)

Yeah, it’s quite easy to work around; I just wanted to report an inconsistency between reading and live preview modes.