[[^^ (block link across vault) does not work on desktop 1.5.3

Steps to reproduce

Type [[^^

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

I should see a list of blocks from all over the vault, like the “Block links across the vault” callout in Internal links - Obsidian Help says.

Actual result

I only see blocks from the current file. I don’t even see the subtext for the block saying what file it is from.

Environment

SYSTEM INFO:
	Obsidian version: v1.5.3
	Installer version: v1.5.3
	Operating system: Darwin Kernel Version 23.1.0: Mon Oct  9 21:27:24 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T6000 23.1.0
	Login status: logged in
	Catalyst license: vip
	Insider build toggle: on
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 10
	Plugins enabled: 0

RECOMMENDATIONS:
	none

Additional information

Here’s a screenshot of what I see:

It works on the sandbox vault, and it works on my iPhone for the normal vault as well.

I have reinstalled the desktop app, and tried with all community plugins disabled.

If it works in the sandbox vault, there is a problem with your vault specifically.

  • Does [[scratch#^tw]] work?
  • Has the vault been indexed completely?
  • Did you enter restricted mode and restart obsidian?

Another thing, if you have a large vault, perhaps you just need to wait. That is very computationally expensive search.

Heya, thanks for getting back to me!

To answer your questions:

  • [[scratch^tw]] works while just `[[^^tw]] does not

  • I don’t know how to tell on desktop if indexing has happened. On mobile I think I see a screen telling me obsidian is indexing stuff. Is there a way to trigger that on desktop? The command palette does’t give me a hit for index.

  • I hadn’t tried restricted mode yet, had just tried turning off plugins one by one. Tried it now. Doesn’t seem to make a difference, I get the same behaviour as in the screenshots above.

If you have a large vault (many and/or large notes), you just need to wait, possibly a long time.
That is very computationally expensive search.

Did you add some large file recently?

You can try bisecting your vault and see if it help.

Didn’t add any large files, no. Vault size is 6.9mb, which seems on the small size.

[[^^ works on mobile for this vault with plugins turned on so I guess it’s something different between the desktop and mobile apps, or perhaps my machine?

if you copy your vault in another directory and run obsidian with this new directory, does it still happen?

Tried copying my vault contents to another vault and opening that one, and [[^^ started working. I saw an “indexing” pop up alert thing show up. I copied everything but the .obsidian folder so I guess it was something there.

On my original vault, I renamed .obsidian/plugins to .obsidian/not-plugins and opened the original vault again. [[^^ was now working. Renamed .obsidian/not-plugins back to .obsidian/plugins, restarted, and it still works.

I guess just opening another vault triggered reindexing or something. I’m not sure. But it does seem like the issue is gone.

Thanks for walking me a solution!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.