Blank & slow-to-load page

Steps to reproduce

  • Open a long file / file with a lot of dataview table, the page slowly loaded or simply showing blank page

Expected result

  • The page should load as normal and should not show blank content

Actual result

  • The page is slow to load, especially long page / with a lot of dataview. And it shows blank page, once in awhile

Environment

  • Operating system: macOS Monterey Version 12.4
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.15.3
    Installer version: v0.14.15
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:22 PDT 2022; root:xnu-8020.121.3~4/RELEASE_X86_64 21.5.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: ITS Theme
    Snippets enabled: 7
    Safe mode: off
    Plugins installed: 47
    Plugins enabled: 45
    1: Calendar
    2: Focus Mode
    3: Sidebar Expand on Hover
    4: Admonition
    5: Advanced Mobile Toolbar
    6: Dialogue
    7: File Explorer Note Count
    8: Recent Files
    9: Sort & Permute lines
    10: Tag Wrangler
    11: Show Current File Path
    12: Excalidraw
    13: Advanced Tables
    14: Ozan’s Image in Editor Plugin
    15: Footnote Shortcut
    16: Better footnote
    17: Kanban
    18: Dataview
    19: Advanced URI
    20: Metadata Extractor
    21: Customizable Page Header and Title Bar
    22: Block Reference Counter
    23: Gallery
    24: Mousewheel Image zoom
    25: QuickAdd
    26: Editor Syntax Highlight
    27: Obsidian Leaflet
    28: Annotator
    29: Spaced Repetition
    30: Collapse All
    31: Note Refactor
    32: Outliner
    33: Banners
    34: Citations
    35: Copy Block Link
    36: Breadcrumbs
    37: Highlightr
    38: Find unlinked files and unresolved links
    39: Imgur Plugin
    40: Image Toolkit
    41: Tag Page Preview
    42: Sortable
    43: Media Extended
    44: Obsidian Columns
    45: Style Settings

RECOMMENDATIONS:
Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

When you made this bug report, there was a template, and it said:

Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help.

Have you tried that yet? You’re running a lot of plugins. And it could very well be one of them causing the trouble.

Yeah, probably community plug-ins, especially dataview. I open a file with a lot of embedded Dataview pages and it takes awhile to load the page. Before the page is fully loaded, I immediately switch to a new page, rendering that new page blank.

  • Temporary solution: command E to switch back & forth between edit mode & read mode.