Black screen after launching iPhone/iPad app

While installing and exploring the Obsidian application on my MacBook Air, iPhone and iPad, I bumped into a strange bug.
When I wanted to open the iPhone/iPad applications, I first see the obsidian stone, and then the app freezes on the black screen. I cannot reach the vault that I have created on my MacBook Air.
I’ve done research on the forum.
I saw some solutions like disconnecting and reconnecting Obsidian from the permission to sync with iCloud. I tried it and it doesn’t work.
I tried to re-initialize/turn off turn on the devices as well as deleting and reinstalling the applications nothing works.
For now, I haven’t installed any plug-in.
I would appreciate your help.
Thank you .

1 Like

You could try the steps here, at first, to see if it helps any:

Thank you.
In fact, when I was trying to fix it on my own, one thing I tried was to delete the Obsidian folder from the iCloud and make sure it disappears on the Mac, iPhone and iPad.
Does it make the removal that you suggested?
Otherwise, strangely when I installed again, Obsidian, it did not create a folder on the route of iCloud (or is it supposed to do?)
(I also made you remember that the first time I installed Obsidian, there was a folder created on the iCloud route, and on the icon of the folder there was the logo of the Obsidian)

Maybe I should describe again, in more details the whole thing.
I started by downloading Obsidian on Mac and iPad.
However, I have created the first vault using the iPad application.
I remember noticing that a folder was created in the iCloud with the Obsidian icon added on the folder.
Later, I opened the same vault on my Mac, and did some tests opening various Notes, etc.
Later, after watching some YouTube tutorials about how to use Obsidian, I decided to start all from zero, and therefore deleted the Obsidian folder.
From that moment on, the problem appeared.
First of all, whenever I created vault, it was itself on the route of the iCloud and not inside an Obsidian folder.
Then, it was not possible anymore to use the iPad/iPhone obsidian application, because straight straight after launching it, I would see the Obsidian icon on the screen, and then a black screen.
During my first search on this forum, I followed the proposition to turn off and again on the synchronization of Obsidian with the iCloud on my Idevices. Which I tried, and it didn’t work.
I also read ariehen’s advice to remove the .obsidian invisible files. Which in a way I couldn’t do because I have already deleted the Obsidian folder itself.
So is the real beginner with this application, I really hope that someone can help me to find a way to make it function.
Many thanks to all all of you

Okay. Maybe the paths are wrong?

On desktop Obsidian, your vault(s) can be most any folder you have access to. It can be on your Desktop, in Documents, even on an external drive (as long as it’s always connected), etc.

On mobile Obsidian, you only have two choices:
On My iDevice/Obsidian/{VAULT}
iCloud Drive/Obsidian/{VAULT}

You can have multiple vaults and use both locations, but that’s it. Since you want to use iCloud Drive, your vault(s) need to go in that Obsidian folder in iCloud Drive. e.g.,

iCloud Drive/Obsidian/VAULT1
iCloud Drive/Obsidian/TestVault

Here are four vaults in iCloud Drive:

Screenshot 2024-03-12 at 18.20.11

The Obsidian folder in iCloud Drive with the icon isn’t a vault, your one vault folder or five vault folders go in there. You may have opened that root folder as a vault on the desktop, so the paths are wrong between desktop and mobile.

This is up to you, but what I would do:

  • force quit Obsidian on the iPad and iPhone.
  • on macOS, move anything Obsidian related in iCloud Drive out to your desktop for safe keeping.
  • wait a bit for iCloud to sync that change to the iOS devices.
  • on iOS or iPad OS, launch Obsidian, and create a new vault (any name is fine) choosing Store in iCloud. Add a note or two.
  • back on macOS, in iCloud Drive, you should see the Obsidian folder with the vault you just created inside that, and the note(s) you created inside that.
  • on macOS, in Obsidian, use the vault switcher to Open folder as vault the new vault you just created, not the Obsidian folder itself.
  • move any old notes you may have into the new vault, but don’t move any vault folders back in just yet.

Hopefully that helps a bit.

Hi ariehen
Thank you so much for your quick answer.
I have done all the steps down below:

I even deleted and reinstalled the application.
Then I turned off sync on iCloud, launch the app to see that it works (of course, without creating a vault using store on my iPad).
Then I quit it. I activated again the sink to the iCloud.
Then I launched the app, and got the same: the obsidian picture, and then a permanent black screen…
So I could not go and complete the other steps you have proposed.
Is there anything else possible to try?

1 Like

Is the black screen issue only on the iPad at this point, or both the iPad and the iPhone?

If there are no vaults in iCloud Drive/Obsidian/, Obsidian may be trying to open an old/broken vault in On My iPad/Obsidian/. Using the Files app, I’d have a look in there. If there are any vaults, try renaming them.

Force-quitting and re-starting Obsidian should bring up the manage vault screen if it can’t find a previous vault or there are no vaults in there / iCloud Drive.

Hopefully someone can spot something we missed or another thing to try.

I have exactly the same problems. Everything worked until I was running with iCloud. Then I decided to subscribe to Obsidian sync, as in part I wanted to support the company. The result is that I am not able to use obsidian with my iPad nor iPhone any longer. This is frustrating and disappointing.

Things are the same on iPad and iPhone.
As for folders :
I notices that there is an Obsidian folder created on the my iPad / My iPhone every time I dowloaded the app and turned off the iCloud sync.
it was impossible to delete it (the delete option was not in the contextual menu).
And again, each time I reconnect the iCloud sync, the app does not move beyond the black screen…
However, every time I deleted the app, that folder disappeared.
I’m open to try any other advise.
Feeling sad that such an amazing app cannot be used and that Obsidian is silent as its black screen…
I couldn’t find any way to connect with the programers team.
I left a comment on the app store, and let’s see.
Anyone who resolved this problem?

That’s the app’s non-iCloud data folder — you don’t want to delete it (it’s normal for it to be deleted when the app is uninstalled). Any non-iCloud vaults will be stored there.

By searching through the forum, I found that someone posted the solution to my problem I described above. The solution was given by mfdoom. Essentially, you don’t need to log out from iCloud on the entire iPad/iPhone. It is sufficient to block Obsidian from using iCloud services. Follow the link above, there is a nice explanation.

Thanks Andrea,
I have seen that post and followed the advise… several times, with no positive result…
It just didn’t work and the bug persists.

Sending the request again just in case someone has a solution. Thank you.

Strange. It worked for me for both iPhone and iPad. What I also did was to first remove the app and all data related to the app that were stored on my iPhone/iPad. There is a menu in the Settings where you find the storage of the different apps. You can delete the app and the associated content. And of course, disable the iCloud connection for the Obsidian app as suggested in the other post once you have installed the app again. Then launch it and cross fingers.

I’m dealing with the same thing.

I’ve been using it for about a month with no issue but ran into some strange things last night where parts of my vault would be moved to iCloud trash. I moved it back (and have now backed it up) but I can no longer open my vault on my iPhone. The screen is black. Once it let me see my vault but I couldn’t tap on Enter Vault.

I’ve tried uninstalling and reinstalling the app, turning off iCloud access but it hasn’t worked so far. I’m going to try deleting the vault from iCloud next. For some reason my iPad still has access to the vault and can open it no problem.

The only thing I was messing around with last night was the CSS Editor plugin on iOS. (Not sure if that is relevant)

Fwiw, I was able to fix my issue by disabling that plugin.

Just to let everybody know, after a long research, I have found a solution:

  1. I backed up all my vaults out of the obsidian folder
  2. I deleted the vault and the folder on my iCloud
  3. I deleted the applications on my iPad and iPhone (there was never a problem with the application on the MacBook)
  4. I have logged out out of my iCloud, waited a while, and logged in again.
  5. It took, of course, quite a time for all the iCloud based applications to be recharged with her data (Notes & Freeform for example and some other non native ones like so make sure the data is fully charged before you need to use these apps somewhere with no phone network nor wifi :wink:).
  6. I downloaded the Obsidian apps on iPhone and iPad.
  7. I asked to create a vault on the iCloud (I just created a temporary vault that I deleted later)
  8. The good obsidian folder was created in the iCloud (which means, with the obsidian logo on the classical folder icon).
  9. I copy and pasted my backed up volts into this folder.
  10. The iPad/iPhone apps work again, which means that after a short moment of a black screen with the obsidian icon, the vault screen appears.

Thanks to all for your support !!!