BibNotes Formatter: New Plugin to Export and Format Annotations from Zotero into Obsidian

I’m facing the same problem too! Looking for any developpement on the issue. :wink:

The update to the newest release solved my issue. Thanks!

What resolved it for me, thanks to the developer and @hyperconnected, was reducing the path name. Previously, the relative path name I was using was the one copy and pasted from Mac Finder (e.g. /Users/u8008006/Documents/Obsidian/Zettelkasten/My Library.json). The correct relative path for me was simply ‘My Library.json’ because I wanted to keep the library file in the root of my Zettelkasten vault (i.e. the file in among the folders in my vault). I hope this helps others, although the dev is adding more info in the next version of the plugin.

@stpag just wanted to say thank you for developing this plugin! I was having trouble mirroring my Logseq workflow of being able to reference highlights from Zotero with the Citations plugin and this was a lifesaver!

Hiya, had a question. Is it possible to use this program with multiple collections/libraries? I have separate group collections for group projects along with my own personal library. Is there a way to use both or to switch between the two in an easier fashion?

1 Like

Hey everyone,
first I wanted to say, this plugin is awesome and has a lot of potential! Thanks @stpag for putting so much effort into it!
However, I’ve encountered problems setting it up. When I import annotations into Obsidian it only shows highlights, no comments and no tags. I put all the details and an example file into this github request: Comments and Tags are not imported from Zotero · Issue #130 · stefanopagliari/bibnotes · GitHub
Maybe someone here has encountered a similar problem? If so, please share.

1 Like

was able to reproduce this on my Macbook (macOS 12.3.1), same versions of Zotero, Obsidian and BetterBibtex respectively as mentioned in the GitHub Post above.
Set it all up from scratch, got the exact same result as described above.

2nd follow-up:
If I toggle “always place the comment made to a highlight before the text of the highlight” it suddenly works like a charm.

If you don’t mind me asking…how did you solve this? I’m stuck with this issue. I’ve checked the export setting and I am exporting notes to the .json file. I’ve also right clicked and selected “add note from annotations”. However, I cannot seem to have my annotations be placed into my created note or updated into it

Any suggestions?

OK! So I think I’ve figured it out but this does raise a question about the add on.

I moved my bib.json file into the vault but not in a subfolder. When I did this, my annotations exported just fine.

I’m thinking the reason why it didn’t work in a subfolder was because my file paths became too long. My pdfs are named by author, year, and first word of title. I’m wondering if why I couldn’t extract annotations was due to the fact when the json file was in a subfolder, the path became too long to process.

Not sure about this but I wanted to let someone know who has a problem with the annotations exporting that it could be related to this.

1 Like

I have just change my Zotero- Obsidian workflow. This plug-in is really good but you have to extract your pdf annotations into notes in order to bring them into obsidian…with the Zotero Integration plug-in you can skip this step and import your pdf annotations, including the images, directly into obsidian. It uses the nunjucks templating script to configure the imported annotations.

1 Like

Link to the plugin?

1 Like

Hey jpchauny, does this plugin work on ipad? I’m trying to figure out full workflow to take notes and annotations from Zotero 6 directly into Obsidian without having to go back to desktop.

Locating it inside the library? What do you mean by that?
I have the problem that Obsidian can’t find anything even though I’ve told the tool the path to my betterbibtex json file. I thought the cause of that may may be the location (OneDrive folder). Now that I’ve stumbled across this comment of yours I maybe have to store the json file “inside the library”. But where exacty do you mean? :slight_smile:

The path to the .json file is the path to the file that is inside a folder within your vault. For example, I’ve created a folder called “Zotero” inside my vault, then I put the .json file in there and set up the path to “Zotero\My Library.json”.

1 Like

Ooooh! Now I get it! Must have overread that xD Thank you!

Having the same problem here.

  • If I set “always place the comment made to a highlight before the test of the highlight” it works
  • ‘ToDo’ comment it works partly (makes a checkbox, but doesn’t display the comment).
  • % Comment works

First had the json file in a subfolder. Moved it to the main folder, but didn’t solve the problem.

Has still somebody got this problem or could solve it?

Hi everybody. I just wanted to explain the lack of updates and fixes over the last couple of months. Unfortunately with the beginning of the academic year, the free time I have in my hands to dedicate to this plugin is extremely limited. I’m still using Zotero, Obsidian, and this plugin in my workflow, and I hope to have more time in a few months.

In terms of development my priorities are:

  • find a way to automatically import the annotations directly from the Zotero database without having to update them in zotero (I would welcome suggestions on how to read the sqlite zotero database)
  • bring the plugin to the list of community plugins
  • incorporate a number of the feature requests that I have received here and on github

Thanks a lot for the update, much appreciated. Regarding the access of Zotero 5 sqlite database, I can recommend you looking at how this library does it. I use it to push highlights, annotations and metadata from Zotero 5 onto Readwise. It is written in Python but the web API from Zotero has wrappers for JS, TS and others.

1 Like