Better PDF Plugin - Insert, scale, rotate and cut-out pdf pages into your notes

Can you please add a feature so that it accepts Zotero URI in url. That would be awesome and much more useful than linking to pdfs in the vault.
Thanks

2 Likes

hello, did you find the problem, I have the same error…thank you

Hi I was wondering if you were thinking of adding support for external system links to open pdfs located outside of the Vault?

It’s a bit tricky since most of the external systems dont support hyperlinks. Currently im looking for a solution where i could manage my epub ebooks and my pdf papers that supports hyperlinks (to quote or to annotation, or at least to a page). Do you have a software in mind you would like to integrate?

I was thinking of being able to use external links like these “file:///Users/XX/Documents/Interesting%20reads/FULLTEXT01.pdf” so I can view them in Obsidian without moving them into my vault. That’ll save my vault space and also improve Obsidian as my personal directory

Is there any way to forbid hovering pdf document when I move my mouse over inserted pdf page with the use of this plugin?

Update: the solution was setting the page preview option disabled. Now it’s great!

1 Like

I’d love to get rid of the hovering pdf whilst still having the page preview components. Is there anyway to do this?

1 Like

Hi,
I‘m trying to get this plugin working in Obsidian 1.0.5. on iPadOS 15.2. using

```pdf
{
“url” : “CT-1.pdf”,
“Page”: 2
}
```

The pdf file is in Vault, in the same folder as the note is.

But I do not see the pdf in preview mode.

When I intentionally include an error in the snippet (eg add a comma in last line), I get a JSON parse error, so the plugin seems to respond.

  • Any ideas what I‘m doing wrong?

Thanks a lot for any comment…

I believe this plugin has a bug in it that prevents it from working properly on iOS. I use it a good bit on windows, and I have a vault mirrored to iOS via iCloud Drive and all my embedded PDFs break with the Better PDF plugin enabled. Worst part is that it also breaks normally embedded PDFs, which just show as a blank page. I recall reading a post some time ago by the plugin author – though I can’t find it now and my be mis-remembering – saying the he doesn’t use iOS and getting the issue worked out there is low on his list.

Thanks a lot, ja_rule !

I ran into an error that I cannot seem to figure out. I tried to move all my pdfs into a subfolder and access them their. However, now I always get the error " TypeError: undefined is not an object" even if I move the pdf back into the main vault.

Any idea what could have happened here?

Thanks very much! I really enjoy the plugin otherwise!