Behaviour when starting a line with -

Things I have tried

What I’m trying to do

HI, I’m sure I’m doign something wrong, but I’ve just installed obsidian on a different mac and when I try to start a line with a dash (e.g. to create a checklist, or to create a bullet), the cursor jumps up to the line above and I can not get back to the line to complete the note or checklist - either by using the arrow keys or the mouse. It seems to work at the top of a document but not following other text.

So, more specifically, after typing some text, I start a new line, type ‘-’, type space, and at that point the cursor jumps to the line above and will not return to the line in question.

I’ve tried disabling all community plug ins and changing the theme.

1 Like

I experience the same behavior when I type space after a -.
However when using tab it works as expected and creates an unordered list.

1 Like

post a screen recording using the help vault

Thank you. Strangely, creating a new vault so that I could do this without sharing information of my current vault seems to have solved the problem.

The help vault works for me too.
My own vault however not:


1 Like

That’s exactly what I was seeing, although at the moment it’s started to work after I switched to a new vault and switched back again.

You either set up some strange shortcuts or some plugin is creating this problem.

I haven’t changed any shortcuts as I just started using Obsidian and the issue also occurs without any plugins installed. The only thing I did was drag and drop a markdown export file of Notion into my vault. The issue seemed to have started after I did that.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.