Basic question: Where is Reveal in Finder? (Mac)

I want to open a note in the filsystenm via Finder (on Mac).

I found a forum post talking about the Reveal in Finder action – but I cannot find it!

When I right-click a note in Obsidian’s File Explorer I do not get this option.

I am working on a Mac with files in the iCloud Drive and I can see the files in the Finder when I manually navigate to the vault in the Finder.

Do I do something wrong?

This is what I see when I right-click on a file in the Obsidian File Explorer using the Sandbox Vault →

Could you take a screenshot of your menu?

Also, have a look here →


If a note is already open, you can also use:


Thanks for chiming in @ariehen !

Here you go:

I have no community plugin installed and the only thing I have consciously changed is the theme to the light one.

I still thibk I do something wrong here. Does this maybe related to my filesystem backend iCloud Drive?

I tried this too. Here is what I get:

Note: Reveal in navigation does not open Finder but just highlights the note in Obsidian’s File Explorer.

1 Like

Thanks for the screenshots. Better picture of where we’re at!

That looks like a very old version of Obsidian from the theme and options shown (pre 1.0). Have you not updated for a specific reason?


Yep, you’re right, Reveal in Finder and Reveal in navigation are discrete commands that take the user to different places. As @ariehen asked, what Obsidian version and installer are you using? (Obsidian > Settings > About)

My vault is on iCloud Drive, so the location should be fine. The icons displayed look like they are from an earlier install of Obsidian, so that might be the issue.

Under Apple > System Settings > Privacy > Files and Folders is there anything there restricting Obsidian’s use?

Ups, yes, I was on a super old version from 2021! (I am traveling with a laptop where I had downloaded Obsidian before it even had an About dialog with a version!!!)

New version sorts it all. Thanks @ariehen and @eightning for chiming in and trying to help!


That made me laugh :joy: cheers for that!

Glad it’s sorted!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.