Backslash '\' auto-inserting into inline code

Steps to reproduce

create a normal table with at least 2 columns and 2 rows

type into one of the cells this bit of code: ls | column

Did you follow the troubleshooting guide? [Y/N]

Yes, the bug persists even in sandbox mode

Expected result

I would expect to see my code exactly as I entered it: `ls | column`

Actual result

Instead of seeing the code I typed, a backslash is auto-inserted into the middle of it like so: ls \| column Deleting the '' results in the ‘|’ being deleted as well. I cannot figure out how to type my inline code without the backslash getting auto-inserted.

Environment

SYSTEM INFO:
Obsidian version: v1.6.3
Installer version: v1.5.12
Operating system: Windows 10 Pro 10.0.22631
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Minimal v7.5.4
Snippets enabled: 0
Restricted mode: off
Plugins installed: 14
Plugins enabled: 11
	1: BRAT v1.0.1
	2: Advanced Tables v0.21.0
	3: Breadcrumbs v4.2.35-beta
	4: Colored Tags v5.0.0
	5: Dataview v0.5.66
	6: Highlightr v1.2.2
	7: Minimal Theme Settings v7.5.0
	8: Open vault in VSCode v1.2.2
	9: Outliner v4.8.1
	10: Paste URL into selection v1.7.0
	11: Style Settings v1.0.8

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I don’t see the screenshots I added in my original message so I’m posting them here just in case.

Here are two screenshots of the bug, one from my notebook and one from the sandbox:

Screenshot 2024-06-10 231444
Screenshot 2024-06-10 231529