Backlinks not recognized

Steps to reproduce

  1. Make a file
  2. Make a file
    1. Insert a link to like this: [[a | link to a]]
  3. Click link in, navigate to
  4. Open the backlinks pane

Expected result

  1. You see a backlink from

Actual result

  1. There is no backlink, but it finds it as an unlinked mention. Clicking Link breaks the link in by wrapping the file name in brackets again


  • Operating system: osx 10.14.6
  • Obsidian version: 0.6.4
  • Using custom CSS: no

Additional information

In 0.6.0 links with spaces around | were not recognized when navigating through them, and that got fixed and is working on 0.6.4, but it seems like the same kind of recognition wasn’t applied to the backlinks detection. It would be lovely go have this fixed.

For reference, wiki links on MediaWiki support spaces around the pipe. You can test here for example and pressing preview to see the rendering above the editor.

Here are some more docs about wiki links:

For example the “Word-ending links” could be an interesting feature for the previews :smiley:

1 Like

Sorry, I can’t reproduce this. Can you try again?

Well my assumption is wrong about the spaces around the pipe because as you said my steps to reproduce do work… Sorry.

I have files with a uuid as the name, and this is what happens to me:

See the Online events markup, I cmd+shift+clicked it and it opened the right note. But when I focus it it isn’t on backlinks and it does show on unlinked sections with the paragraph I just came from.

I tried to re-test the simple example by changing the file names to have - in them or putting them on a subfolder (all my files are in a content folder), but those worked well. I am not sure of what else I could try to test why this didn’t work :frowning_face:

I’m experiencing what I think is the same bug with different syntax. Standard markdown links with titles appear under “Unlinked mentions” rather than “Backlinks”.

Steps to reproduce

  1. % touch
  2. % echo “[a](a)” >
  3. Open Obsidian on the directory containing and
  4. In Obsidian, navigate to a.
  5. Open Backlinks pane.

Expected result

The referencing page appears under the Backlinks category.

Actual result

The referencing page appears under the “Unlinked mentions” category.


  • Operating system: Ubuntu 20.04 LTS
  • Obsidian version: v0.6.4 AppImage
  • Using custom CSS: No custom CSS.

Additional information

The problem seems to occur regardless of what title is used. (For instance “[a page](a)” suffers from the same issue.)

See attached screenshot:

So basically it is a linked mention, but it shows as an unlinked mention?

@lukasf at the moment we don’t handle standard makdown syntax for the backreferences.

1 Like

Yep exactly. I’m not sure what the problem may be. This are the real file names:


# Online events


# Why online events are boring, and how to make them better

* [[3fdf5f75-b03b-4b6d-9d2a-a1a26f54a7c4 | Online events]], [[72e73333-8e9f-4283-8278-d6712bc24a27 | Developer Advocate]], [[1d06a77a-e11b-492c-b533-de3b4b759a18 | Article]]

Reasons why virtual events are boring:

@WhiteNoise I’ve changed the markdown to be:

# Why online events are boring, and how to make them better

* <>
* [[3fdf5f75-b03b-4b6d-9d2a-a1a26f54a7c4 | Online events]], [[72e73333-8e9f-4283-8278-d6712bc24a27 | Developer Advocate]], [[1d06a77a-e11b-492c-b533-de3b4b759a18 | Article]]


I just wrapped the link in the previous line with < >, just trying random things.

And now it shows as a linked mention, instead of unlinked like before. So something seems to be wrong related to the link in the previous line.

It is possible that there is nothing wrong and the links are recognized, just not immediately.
Maybe our internal data structure hasn’t been updated yet. There is a fix in the next release 0.6.5.
Let me know if it solves for you.

Sure, will do!

I’m not sure if that would be the case since changing the previous link has an immediate effect on how the backlink is recognized. Here is a gif:

Is the issue fixed for you?

I can’t reproduce any longer on 0.7.3, so it seems fixed :+1:

I cannot backlink my links. They won’t come under Unlinked mentions but I can see them in the Linked ones. Where could I go wrong?


you posted the same image twice

The duplicate is deleted.

Miah I don’t understand what your problem is.
What do you expect to see under Unlinked Mention?
Do you have other notes that contain the word “ethical dilemmas”?

Yes, I do and I expect to see those notes under unlinked mention to link them to ‘ethical dilemmas’, as it is explained in this tutorial, Or am I missing anything?

Can you post a screenshot of one of the files that you expect to see in unlinked mention of ethical dilemmas?

I got the answer from a different source. It turned out that my notes were already linked, that is the keywords were written as links not just exact words, therefore they didn’t come up as unlinked, which makes a lot sense to me now.

Thank you for taking your time.