"Backlinks in document" do not retain preferences like "Collapse results"

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

  1. Enable “Backlink in document” under Options > Core plugins > Backlinks.
  2. Open a note and scroll to the backlinks at the bottom of the document.
  3. Change the view settings like “Collapse” or “Change Sort Order”.
  4. Quit Obsidian & reopen.
  5. Look at the backlinks section to see the preferences are not retained.

Expected result

The preferences for backlinks in document should be retained.

Actual result

I have to keep manually changing the settings via mouse to get the view I prefer.

After every restart I:

  1. Click to collapse results.
  2. Click to sort by modified.
  3. Click “Unlinked mentions” dropdown to expand the section.


  • Operating system: macOS Monterey 12.1
  • Obsidian version: 0.13.12

Additional information

We don’t support this. Open a feature quest.

Okay, I will. This is supported in the backlinks pane though, right? I just assumed they would both retain it.

Not sure if you did … but I did if … Give plugin options for backlinks plugin for the different options (see details)

1 Like