Auto Pair Markdown Syntax Malfunction

Issue: Even when “Auto pair Markdown syntax” is disabled, Markdown signifiers like * and ** are auto-paired when using ⌘+I to format for Italics or ⌘+B for Bold, but the same command does not escape the pair.

Obsidian v0.12.10 for MacOS
Obsidian v1.0.2 for iOS

Steps to reproduce:

  1. Invoke Italics with ⌘+I and asterisks appear: *|*
  2. Type “text” and text appears italicized: *text*
  3. Close Italics with ⌘+I and new italics set appears: *text***

This issue can also be reproduced in Obsidian Mobile by using the I button on the Mobile Toolbar. Pressing the button once brings up the pair of asterisks and pressing it again produces a new pair.

not a bug. check how italics is done in markdown.

“Auto pair Markdown syntax” is described in the Editor settings as “Pair symbols automatically for bold and italic”. If I turn that feature off, shouldn’t ⌘+I produce only one asterisk?

Maybe I’m not explaining the issue very well. Here’s the discussion thread on Discord with initial post:

Oooweee, I sure am confused! I’m trying to use Markdown Italics, and if I type *, I get a pair of asterisks around my cursor. The same thing happens if I type ⌘+I, and this is fine. I like the autocomplete. What I don’t like is that there’s no clean and easy way to get out. If I type * again, then I have three asterisks. If I type ⌘+I again, I get another set of asterisks. It seems like the only way to get through the end of the formatting is with the arrow key, unless I’m completely missing something. What is the right way to close Markdown formatting for bold and italic, besides just typing the asterisk(s) again? Should I be filing a bug report?

With “Auto pair Markdown syntax” on, typing an asterisk (shift 8) produces a pair of asterisks.

With “Auto pair Markdown syntax” off, typing an asterisk (shift 8) produces a single asterisk.

CMD I (which isn’t markdown syntax) produces a pair of asterisks irrespective of the “Auto pair Markdown syntax” setting.


Ok, there is no open italic close italic. There is just italic within. Use arrows or ctrl-right to move to the next word

1 Like

Thanks for this clarification. On Obsidian Mobile V1.0.2, toggling the “auto pair Markdown syntax” has no effect, but I understand its function on the Mac side of things.