Audio not working in iPad synced to MacOS

Steps to reproduce

on MacOS

  1. Create new vault
  2. Drag an mp3 audio file onto the welcome page and check that it plays
  3. Activate Sync plugin
  4. Create new remote vault, connect to it, turn on audio syncing and start syncing

On iPad:

  1. Connect to the newly created vault, turn on audio syncing
  2. Go to welcome page, audio file just added is visible but won’t play.

Did you follow the troubleshooting guide? [Y/N]

yes

Expected result

That by clicking on the playbar play icon in the file my audio will play

Actual result

The play icon changes to a pause. icon but the audio doesn’t play

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.2.0: Fri Oct 13 09:27:54 PDT 2023; root:xnu-10002.60.54~14/RELEASE_ARM64_T6000 23.2.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

This is a limitation of web engine used on iOS (safari). It al;so depends on the codec used in that specific MP3.

I don’t know which version of iOS you have, but you can try to update it and see if it help. If it doesn’t, there isn’t much we can do.

This seems strange. I discovered this recently in a vault in which 3-4 weeks ago all audio was playing just fine on the iPad. Also, this same vault, synced to on an iPhone, is working as expected.

I’m running iPadOS 17.4, which I see now is a public beta, released about a week ago … I’m considering reverting to the public version, see if that works. Do you wish to be kept informed on this?

iPhone is 17.3. reverting the ipad makes even more sense, I think.

FYI: Reverted iPad to iPadOS 17.3, all working.

FWIW, Notion has the same problem with 17.4; won’t play audio added to a page in MacOS

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.