Attachments on Mobile (Android) shows as xxxx.jpg is not created yet

Things I have tried

I recently started using obsidian on my android phone. I have setup in settings that all attachments goes to a folder i have created in Obsidian called files

Yesterday i made a page with multiple attached images and everything seemed fine, all the attachments were in my files folder and they displayed as they should on the page i created.

Then today when i open up that same page and 5 of the 7 images now shows as ‘‘xxxx.jpg is not created yet. Click to create’’. I then checked my files folder and they were not there anymore.

I read the following post: Attached files - #11 by alltagsverstand to learn more about how Obsidian uses pictures stored inside and outside your vault. But there are still multiple things i don’t quite understand.

From what i understand when I attach a picture and its placed inside my files folder then its now placed inside my vault. And the location where the picture is placed inside my vault is now the source destination of said picture. I even checked the location on my phone storage where the files folder is located together with my other pages in obsidian and the majority of the picures that was there yesterday are not there anymore.

The pictures I attach originates from my photo gallery on my phone, and sometimes I can reproduce the issue by moving the picture I have attached inside obsidian from one folder in my phone gallery to another. resulting in the picture now displaying as ‘‘xxxx.jpg is not created yet. Click to create’’. But again it has not happened every time I have tried to reproduce the issue this way.
But from my understanding why would this cause issues when the picture I attached in Obsidian should be moved to be inside my vault upon attaching it?

So my question is pretty much if anyone have any idea as to how the pictures go from displaying as pictures one day to the next displaying as ‘‘xxxx.jpg is not created yet. Click to create’’

I have checked app settings and Obsidian have full access to my files and media on my phone.

What I’m trying to do