Arrows aren't pretty - monospace font?

im trying to make some arrows in the “$$” thing. when i type it, its combined, but after i place my curser somewhere else it looks like this “->”

i tried with some different plugins, but i really don’t know.

That’s a theme setting. Try a different them or you could attempt CSS. I’m not real good with CSS but maybe someone can chime in with help on that.

It could be this:

@ariehen , Do you know if Obsidian changed the default font used in 1.5.11 since this suddenly has become an issue? I never had any issue with font ligatures before this version, but I’m frequent enough on this forum to try that when I started seeing the ligatures.

Do you think we should report it somewhere that this font change wasn’t the smartest move, if that is actually the case?

I didn’t notice it myself as I generally have custom fonts set for each viewing mode including monospace fonts.

It has come up a few times, it seems, with the default font changing on Windows.

I don’t know the details, but I believe it’s from here:

  • Update monospace system font stack.

@ariehen in 1.5.11 there is this update

I think that was causing issues for people with fonts changing in the latest update.

1 Like

i tried this font but that isn’t helping sadly

Are you sure it isn’t your theme? Have you tried on the default theme or a different theme?

In math blocks, (the “$$” thing), you should include arrows using latex code, i.e. \rightarrow. What also works is to insert dedicated unicode characters, e.g. Rightwards arrow “→” (U 2192).

ah thank you. i didnt even know that existed

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.