Application Icon missing in Gnome on Linux

Steps to reproduce

  • Install the app.
  • When switching between apps in Gnome using CTRL+TAB, the Obsidian app is missing an icon, which makes it very ugly compared to other apps.
  • Is this due to the Appimage format?

Expected result

To see an application icon in the app switcher.

Actual result

No icon exists.


  • Operating system: Arch Linux with latest Gnome 3.36
  • Obsidian version: 0.6.5

Additional information

This may seem like a small issue but since quite a lot of Linux users enjoy customizing and making their desktop look good, this could be reason enough to use another app. So please fix this. Hopefully an easy fix.


Possible workaround for now: GNOME Desktop Installer

I have the same issue with the snap package.

I had trouble with getting the icon to show up on the task bar. The solution ended up being adding the line StartupWMClass=obsidian to the .desktop file

1 Like

My .desktop file has the line StartupWMClass=obsidian, even so, the icon is not displayed on the gnome taskbar (Dock). The strange thing is that, in the application menu and in the search, it appears.

Obsidian in version 0.7.6 (AppImage)
OS: Pop_OS 20.04
Gnome 3.36.3

1 Like

Same problem on the latest Ubuntu 20. Installing the AppImage via AppImageLauncher.

I solved this by installing the Snap package instead. Previously I’d selected the AppImage because the Snap file wouldn’t install. But got it working with these instructions: Hot to install Obsidian snap on Ubuntu?

I’ve tried this and the furthest I’ve gotten is downloading the icon. But when I open up my list of applications and click on Obsidian, it doesn’t open anything. I may be missing a link between the bash script and the icon itself

Had the same problem after installing Obsidian with AppimageLanucher. The solution for me was changing from StartupWMClass=Obsidian to StartupWMClass=obsidian in my obsidian.desktop file. Also my obsidian.desktop file for some reason isn’t located in the usual /usr/share/aplications folder but in /home/USER/.local/share/aplications.

Obsidian in version 0.8.4 (AppImage)
System: Ubuntu 20.04.1 LTS
Gnome 3.36.3


Thank you for this reply, now Obsidian is integrated well in my PopOS :slight_smile:

I was facing the same issue while using the Obsidian App via AppImage, but in my case os is Xubuntu i.e. XFCE DE. Below are my Desktop entry based on the actual AppImage location:

[Desktop Entry]
         |--- obsidian.AppImage
         |--- obsidian.png

I was still facing the issue related to missing icons in both xfce-panel and the application switcher. After coming across this post, I added the icon (the same one which is present in /opt/obsidian/ inside the apps folder of my icon theme as shown below:


Followed by a restart, solved the issue.

1 Like

I am having the same problem.

Also, I find no obsidian.desktop anywhere on my system. Is this file supposed to be created by the AppImage the first time it is launched ?

@srbd yes, I wrote some instructions for that here: Meta Post - Linux tips, tricks & solutions to common problems - #3 by argentum

1 Like

A post was merged into an existing topic: Meta Post - Linux tips, tricks & solutions to common problems

Worked like a charm. Many thanks !