AppImage segmentation fault when opening or creating Vault

Steps to reproduce

Run the 0.8.14 AppImage and attempt to create or open a Vault using the file dialog

Expected result

The file dialog should allow one to select a location of a Vault to open or the location where to create the new Vault

Actual result

The file dialog appears for a few seconds (the last thing that seems to happen is my root directory showing up in the listing), followed by a segmentation fault before a directory can be chosen

Environment

  • Operating system: Pop!_OS 20.04 LTS with GNOME 3.36.3
  • Obsidian version: 0.8.14 AppImage

Additional information

This is the terminal output from running the AppImage:
(electron) 'allowRendererProcessReuse' is deprecated and will be removed.
Loading main app package /tmp/.mount_ObsidimC1IUy/resources/obsidian.asar
Checking for update using Github
Success.
App is up to date.
Segmentation fault (core dumped)

Opening the example “Obsidian Help” Vault works fine and seems to let me use the application. Additionally, the snap app works on my platform but I would much prefer the AppImage. (Pop!_OS supports Flatpak natively instead of snapd, so I would prefer not to require all of the snapd infrastructure just for a single app.) Only other relevant info is that I have a Google Drive location mounted via the OS.

If there is a way to get more verbose output or debug logs I’d be happy to try doing so. I was very excited to try Obsidian so please let me know how I can provide more info. Thank you for your help!

Note that there is an existing topic here but it was closed.

does snap work for you?
I’ll keep the bug open

I can more or less reproduce. Trying to create a vault from the vault switcher doesn’t output a segmentation fault, but doesn’t work. Open an existing folder as a vault works fine.

Where are you storing your AppImage? I believe this should be pointing to ~/.config/obsidian/obsidian-0.8.14.asar

Possibly related problem, with the snap on linux Obsidian crashes when opening the file dialog with the following error in the terminal:

Gtk:ERROR:…/…/…/…/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /snap/obsidian/x2/data-dir/icons/Adwaita/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Aborted (core dumped)

@tychobismeijer I think that bug might be more/also related to this: [Linux-Snap]: Can't reopen after installing from snap