Appimage disappears one second after opening

What I’m trying to do

I am trying to open a new instance of obsidian from a fresh Appimage from the site.

Things I have tried

I have right-clicked and edited the AppImage settings so I can (supposedly) execute the loader, and I have told it to open in Obsidian, which I selected from the dropdown.

BUT when I try to open in Obsidian I get a beautiful black and purple with writing on it that disappears in a second. Then nothing further happens…

BTW…I am running Ubuntu linus 17.10

Thanks for your help

What do you mean by “open in obsidian”? The AppImage actually is obsidian. Right-click the AppImage, go to “Properties”, select “Execute file as programme” (I’m on a German desktop, the English translations might vary slightly…).

After that, just double-click the AppImage and obsidian should open. Or, even better, establish a desktop starter for obsidian, thus it will appear in your applications menu (if you don’t know how to establish a desktop starter: search the web or even this forum - I think I remember there was some guidance in the forum a while ago…).

And by the way: I strongly recommend to install a more up-to-date ubuntu version (22.04 LTS for example) - yours isn’t supported anymore since 5 years! Means that you run the risk of severe security vulnerabilities; furthermore, for many apps the more recent versions won’t be really supported…

Thanks for getting back to me.

I have done all the things you refernce in paragraph 2…repeatedly. Obsidian presents a spalash screen then immediately closes. :hot_face:

Any ideas?

Yeah, It’s an old version of ubuntu. I’m trying to revive an old Dell E5510.

Have you tried installing the debian package? That’s what I use on Ub 20. I don’t like fiddling with the AppImage.

Good thought. Worked like a charm…and closed immediately upon launching.


Don’t know from here. Maybe 32/64 bit dependency issue? You know better from where you’re sitting. Just a thought, again.

What I’m trying to do

Down load Obsidian to ubuntu

Things I have tried

Repeatedly ran routine process with the same negative outcome.


Trying to download Obsidian to Linux using AppImage fromObsidian. AppImage downloads correctly, allows me to edit to check executable permission and to select app to open (Obsidian); even leaves the right icon on Ubuntu desktop. But when I douple click icon to run; Obsidian front end opens just like you’d expect…then abruptly closes for no apprarent reason. Most infuriating…

Any ideas?

Try to open the AppImage from the terminal. What does it say?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.