Android Obsidian thinks it is January 1, 1970?

My Android Obsidian thinks every file was created on January 1, 1970 and every file was last edited on January 9, 1970.

This was first made apparent to me today when I was using the Dataview plugin to bring forth files that were edited recently. I tried Templater and determined that it wasn’t just a Dataview problem. My Android Obsidian thinks every file was made on 01/01/1970 and last edited on 0109/1970. I tried reproducing this problem on my iPhone Obsidian and my Windows Obsidian and both rendered the proper date of 2022.

My actual phone itself knows that it is 2022 so I know it isn’t a problem with my phone itself.

I have tried reloading Obsidian, restarting my phone, and deleting and reinstalling Obsidian. Nothing has worked.

I’m using Windows 10.

I’m using Android 10.

I sync my Vault by using a USB cord connecting my phone to my computer.

Whenever I use these inline Dataview commands:
I get

“11:12 PM - January 03, 1970
1:23 PM - January 9, 1970”

I checked my Android’s File Explorer:
Last Edited 2022.

The filesystem creation and modification time is something that daview offers but we do not support it nor provide any guarantees of its accuracy. Some filesystems don’t even have creation time.

This happens in Templater too so either Templater and Dataview are broken simultaneously or Obsidian is.

This doesn’t happen on my iPhone nor on my PC so this is only a problem on the Android version of Obsidian. This only started happening after the new Obsidian update.

Maybe it is obsidian’s fault, maybe it’s OS, I do not know. You are missing the second part of the answer.

we do not support it nor provide any guarantees of its accuracy.

so it’s not a bug.

This was working just fine before my Android Obsidian updated so my system does support it. Obsidian updating broke it.

I’m not asking for Obsidian to troubleshoot my Dataview problems.

I was told by the Obsidian Discord mods to report this here so they clearly thought it was under Obsidian’s jurisdiction.

And here’s another thing:

These two buttons aren’t working.

Go to file and recent files have do not use the filesystem date.