Aliases automatically add "[ ]"

Steps to reproduce

  • Create YAML with aliases. Then type in any value for any property, except aliases. You then see aliases automatically add [ ].

Did you follow the troubleshooting guide? [Y/N] Yes

Expected result

Aliases should not automatically add [ ]

Actual result

Aliases automatically add [ ]


Obsidian version: v1.4.3
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:21:56 PDT 2023; root:xnu-8796.141.3~6/RELEASE_X86_64 22.6.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: off
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 9
Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information


I don’t consider this a bug. Moved to help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.