Alfred - Obsidian Utilities

Thank you very much for the kind words. I love it when other people find usefulness in the stuff I share.

Cheers!

@macedotavares Big thanks. Really fun tool.

Question: when I use the fallback Google search, the “s” I type when triggering the search action becomes part of the Google search. Is there something I can tweak in the workflow that will exclude that “s” from both bouncing up to Google and getting logged in the Daily Note?

Many thanks :+1:

The “s” search will only fallback to the “logged Google search” (or any other fallback) if it doesn’t find any matches in your notes.

I must admit I didn’t think of that case, and have no immediate answer for you.

Let me think about that for a while.

Thanks for bringing this to my attention. Cheers!

1 Like

Hello!

I’m using File Stream by Google Drive to store my vault, so it’s synced with GDrive and File Stream creates a new Location (like a new disk) in the computer.

Since the vault path takes for granted that the vault is located in the $user folder, is there any way to bypass that to point it towards that new Location that FS has created?

My vault path is /Volumes/GoogleDrive/My Drive/Obsidian, but the workflow is not picking it up.

Hey! Thanks for raising this question. Give me a couple of days to see if I can come up with a workaround. Even if it doesn’t make its way into a new release, I’ll share the instructions with you.

Cheers!

1 Like

Thanks for creating this, but could you or someone give example of how to configure the value fields. For instance this one:
~{var:vault_path}/{var:daily_folder}/{var:date}.md

My path is Documents/Obsidian Notebook/Obsidian Notebook, so how do I plug that in? I seriously need to learn how to do stuff like this. Not sure where you guys learn it. Thanks for the help.

You don’t need to edit those inside the workflow components; only once, in the environment variables pane. That’s the window that opens up upon installation, or when you click the [x] button in the upper right corner of the workflow screen. There are instructions there, too. If you need further assistance, let me know.

Update: Okay, I think I figured out the environment variables; however, the only issue is that Alfred won’t append the specified note text, it just opens to the file in Obsidian.

Also, one more question. My date format in Obsidian is ddd MMM D, YYYY, but when I try to add that to the date variable in Alfred it doesn’t recognize it. Can you tell me how I need to type the date variable in Alfred so it will match in Obsidian?

1 Like

Hi.

I’m guessing there’s something wrong with the vault path you specified, but I can’t be sure.

Please activate the debugging mode on the workflow (by clicking the Screenshot 2020-12-28 at 09.31.53 on the upper right corner) and run the append action; then, send me the log that appeared on the bottom pane on a private message.

If what you want is something like “Mon December 28, 2020”, you should use this:

{date:eee MMMM d, YYYY}

Alfred uses the Unicode format for dates. You can mix and match all the placeholders listed there.

Thanks so much for your feedback. I don’t want to take up your time, but here’s the issues:

  1. When I run the “Add to daily note” workflow, it results in “File Mon Dec 28, 2021.md not found.” The date configuration is 2021 instead of 2020

  2. When I run the “Add a journal entry to note” workflow, it comes back “File 2020-12-28 not found”.

The Search Notes workflow does work.

Again, I don’t want to take up your time, please only reply when it’s convenient for you. Thanks.

There must be something wrong with the vault location. Please activate the debugging mode, try running one or all the broken actions and send me the log via PM. See my reply above for instructions.

[17:04:04.535] Logging Started…
[17:04:15.713] Obsidian Utilities[Keyword] Processing complete
[17:04:15.719] Obsidian Utilities[Keyword] Passing output ‘testing’ to Arg and Vars
[17:04:15.720] Obsidian Utilities[Arg and Vars] Processing complete
[17:04:15.720] Obsidian Utilities[Arg and Vars] Passing output ‘testing’ to Conditional
[17:04:15.721] Obsidian Utilities[Conditional] Processing complete
[17:04:15.721] Obsidian Utilities[Conditional] Passing output ‘testing’ to Write Text File
[17:04:15.724] ERROR: Obsidian Utilities[Write Text File] Unable to write file ‘~Documents/Obsidian Notebook/Obsidian Notebook/Daily Notes/Tue December 29, 2021.md’ as parent folder does not exist
[17:04:15.725] Obsidian Utilities[Write Text File] Processing complete
[17:04:15.726] Obsidian Utilities[Write Text File] Passing output ‘’ to Open URL

Is the problem that I have the vault inside a folder?

Your path is missing a / before Documents.

It should begin with

~/Documents/ etc.

1 Like

Hi @macedotavares! I am getting strange behavior. Everything seems to work perfectly fine but I always get an error with the vault not being found. Tasks, Journal entries, and notes work perfectly. I have tinkered with some values inside your scripts and they still work, but for some reason, the “Vault not found” prompt will always show up.

Any thoughts?

Screen Shot 2020-12-30 at 09.51.39

Screen Shot 2020-12-30 at 09.54.56

You have quotation marks around your vault name and you shouldn’t. It’s probably my fault, because I used them in the setup instructions.

Your vault_name environment variable should be set to mySecondBrain.

1 Like

Absolutely! The thing is I changed the rest “notes”, etc… and removed where I did not find them necessary “To-Do”. I should pay more attention!

Thanks for the fast reply!

1 Like

Hi! Sorry for the delay.

I’m fixing that for the next version. In the meantime, you can set your vault_path to /Volumes/GoogleDrive/My Drive/Obsidian and go through all the workflow components (script actions included), deleting any references to ~ or $HOME. That should do the trick.

And, please, don’t forget to do backups.

If you need further assistance, please let me know.

Just wanted to say this is a great workflow and is incredibly useful - I’m only using the daily journal adding but makes things a lot easier. Thank you for sharing!!

1 Like