After upgrading to 0.15.1, the search function and double-link function are almost disabled

After upgrading to 0.15.1, the search function and double-link function are almost disabled.
For example, in the picture below, you can see that there are several notes named “GRAIL” in the file library, but they are not searchable in obsidian.
In the double-linked panel, there is only one result for notes.



One of the phenomena is that in the search bar and the double-linked panel, there is a progress bar scrolling with constant search. I’ve had obsidian open for a few hours now, and I can’t seem to finish the search.

Side note: I purchased the sync feature and the sync function works fine.

I tried another file library with fewer files, probably less than 20 notes, and the search and backlink functions worked fine.

Currently I have a core notes file library with about 5000 notes, is it because of the number of files that the search function is not working.
But in versions before 0.14.5 the search function was working fine.

Also may I ask how should I return to version 0.14.5?

You may just have to wait until your vault is fully indexed, but maybe something strange is happening. I assume you have no plugins or themes. One thing you could try is to open the sandbox vault and copy your other vault’s files into it.

In terms of reverting to a previous version, I believe you could just uninstall the current version and use the installer from a previous version and disable auto-update.

Good luck!

Thanks for your help, I finally found out that it was a plugin named: Query Control, which created a conflict, and after closing this plugin, the search function is back to normal.