Advanced Tables Plugin

I’m not sure, about the installation. I think I remember having first tried to install from the github repository and it didn’t work. When the “automatic” installation came out, I used it. Maybe that’s why, in the end, I had two folders in the plugins folder :

So, here’s what I did :

  • quitted Obsidian
  • trashed the two folders
  • relaunched Obsidian
  • reinstalled the plugin from the third-party panel

And now the plugin seems to work.

Same thing as @malife : the only defined hotkey is SHIFT–CMD–D. So, I tried to define ⇥⃣ for “Navigate to Next Cell” and couldn’t.

(By the way, there’s as small mistake in the documentation : SHIFT–CMD–D should be written.)
CleanShot 2020-11-02 at 21.14.41

Ah thank you for the heads up about the typo.

Yeah, installing from Github is tricky because you need to be sure to download from the releases page, not the master/main branch. Your best bet now is to install through the plugin browser in Obsidian.

I’m glad you got it to work. Thanks for the update.

1 Like

Just to let you know I have started using the plug-in for making tables, and it works fine. Many thanks.

Thank you very much for creating this. Opens up many options. So happy to have this.

Rather than creating a new post, I am just editing my original post of all that is below this paragraph. I wanted to put out something that has helped me with a slight issue I was originally having. When working with long entries that make for wide columns, it was sometimes difficult to get to see the beginning of the content in the first column when shift tabbing over from the right. The horizontal scrollbar does not automatically bring view of the beginning of this column necessarily. A workaround I have found to completely remove this is to simply add an empty column to the left of the first column. This way shift tabbing over to that forces the beginning of your first real column to be in view. Hope that helps someone use this awesome plugin to its fullest.

Back to original post: This plugin is very helpful for a workflow that allows me to use tables with a column of links and another column with descriptions in cells of how the link in the adjacent column relates to the note the table is contained within.

Although macros do the trick, I wonder if there might be some functionality someone that could extend tables with automation of converting cell entries into links, creating the note, adding a corresponding table in that note and placing the 2 relevant links in place based on parallel setup in first note.

There may be a plugin or extension to yours that is able to do this on a grand scale throughout a vault in coordination with some sort of marking system or perhaps leveraging tags or headings.

Also, being able to arrange links in a super table in such a way that the system automatically updates the links between them based on customizable conditions set on a per column or per row basis. And to have these super tables excluded from graph. Of course, all of this is possible, but would be nice if automated.

Tables within tables would be cool. Also, having line wrap work in edit mode would be cool. While this may seem to conflict with your auto adjusting methodology, I think there could be ways to make it be there only when you want it. For example, maybe when a hotkey is pressed, a new line is started automatically adjusting the entire column to the width when the hotkey was pressed. To extend it again, maybe a different hot key would be pressed allowing the auto adjust behavior to set in.

In additional to this per column line wrap, a global line wrap for the table would be great to force the table to fit on screen while in edit mode. This in coordination with those hotkey adjusters would be incredible.

This is not to say that I am not already completely satisfied with what you have done. I love it. Thanks again.

Small thing. It would be nice to have the ability to add a hotkey for add row. This is actually the one function I do the most often other than alphabetizing. Thanks so much. This plugin is a lifesaver.

Just after posting this I realized I can select and copy an empty row then move cursor to the left of the farthest left pipe and paste it in. This method makes it possible for me to now use macros to do this, but would still appreciate the hotkey functionality, but it is hardly urgent. Thanks again. :pray:

@I-d-as, I’m happy to hear the plugin is helpful to you!

Thanks for pointing out that a hotkey can not be set for adding a new row. I have opened a new issue on the github page to track adding that feature.

In response to your previous comment, unfortunately Markdown does not allow line breaks within a table cell, because line breaks are used to signify the next row. I too find this annoying, but since that change would require changes to the Markdown spec and parser, it’s not something that this plugin can change.

2 Likes

Is it possible to copy/paste an Excel or LibreOffice Calc table into Obsidian via your plug-in? If not, is this a possibility that is doable and can be considered by you? If so, I use LO Calc so would like that to be included, it’s probably not that different from Excel.

1 Like

You won’t be able to do that with this plugin, however there are tools online that can do that for you. For example, https://tableconvert.com/ has an “import” button on the top and will output the data as markdown which you can then paste into Obsidian.

4 Likes

@tgrosinger: thanks for that link ! I tested it, and it makes copy/paste very easy.
Many thanks.

I’m not sure if you currently want any feature requests or if you do, whether this is even the location to do it. I prefer to stay here over GitHub, but am happy to move over there if that is preferred.

I was thinking it would be very cool to have a feature that keeps the column titles visible even when you are scrolled down.

As a workaround, for my tables that have many columns and when the above entries don’t make it obvious what the columns are, I have been adding a row at the bottom that adds zz before column names so that it sorts to the bottom regardless of which column I am sorting by. This works, but it is annoying to retrofit many old tables with this special bottom row.

As I am writing this, I realize that I could just stay at the top and add rows above rather than below so as to keep the titles in view.

Regardless, the feature would be super cool if you didn’t want to have to stay at the top (or bottom) in order to know your column.

Even if it meant having a hotkey to temporarily show it. In fact this gives me an idea of a macro that would temporarily paste it in. And now that I think of it, for tables that I am not using an auto sort so I can’t work from top, I could just open another pane above and double check that so as not to totally lose my flow by scrolling up and checking.

Anyways, sorry about the rambling long post. Thanks again for what you have created. Very cool!

1 Like

How about the ability to merge , split cell, background-colored to cell and row/column , just like in excel?

2 Likes

@brucehan, thanks for the suggestion. Unfortunately those changes require functionality which Markdown does not make possible in tables.

This plugin is only making it easier to edit Markdown tables within the existing format,. so those features are not possible in this plugin.

FWIW, my workaround: a Keyboard Maestro macro:
Option–Return → types “<br>” , which is the equivalent of entering an “EOL”. It’s useful everywhere, not just in table cells.

1 Like

@OlivierPS: inserting <br> does not result in a line wrap in Edit mode, which is what the discussion between Tony and @I-d-as was about.

I checked on internet because I would also like a line wrap in Edit, but I think we’ll have to live without it.

@klaas: inserting <br> does not result in a line wrap in Edit mode

Oh, I see. Sorry. Then, my workaround is to use Typora; it’s very good with tables and if you use <br>, you get a line wrap inside the cell in edit mode. Typora is the best editor I’ve found for tables with a lot of text inside the cells.
The “perfect” editor is yet to come. Until then, I guess our workflows have to include different editors, each with its own strengths and shortcomings. But such is the beauty of Markdown: it allows editing the same text with different tools.

if you use <br>, you get a line wrap inside the cell in edit mode.

@OlivierPS: I use Typora too, and have done so for around 3 years. What you state here is not correct either.

When you put <br> inside a cell you do get a line wrap, but it is NOT in Edit mode. Typora is a WYSIWYG editor, so anything you do is immediately rendered as a Preview mode, although the Preview mode is editable.

If you want the real Edit mode, you have to turn on what Typora calls “Source Code Mode” If you then look at a cell with <br> in it you’ll see it is just as ugly as Obsidian’s Edit mode for tables, with NO lines wrapped. They only get wrapped when you go back to Typora’s normal, WYSIWYG mode.

Furthermore, in Typora’s normal, WYSIWYG mode the <br> tag remains visible in the cell, whereas in Obsidian it disappears when you turn on Preview.

Last but not least, next year Licat will start work on a WYSIWYG mode as a 3rd mode for Obsidian, something I have been eagerly waiting for since I started using Obsidian.

1 Like

Visible < br > in Typora is an option you can turn on and off (Edit/Whitespace and Line Breaks)

Also just a small convenience info - shift+return when editing a table will add a < br > automatically and keeps the cursor within the cell.

2 Likes

Thanks for that, I had completely forgotten about it. I remember now why I kept it visible: with WYSIWYG it is not always clear why there is a break unless you revert to “Source Code Mode”.

Hi! thank you for creating the plugin, helps a lot by not being distracted with formatting as I have slight OCD.

I usually export my notes in pdf to read them on my mobile and I noticed that , while in markdown the tables look really good and readable, they are all messed up in alignment when converted to PDF. How can I fix that?

I am guessing that is because the PDF renderer does not use a monospace font when rendering the table.

I don’t have any knowledge of how the PDF renderer functions, so I don’t have a great answer. Maybe you could render them in preview mode instead?

Sorry I don’t have a better answer here!