"Add internal link" hotkey not working when editing properties

Steps to reproduce

  1. Create a text or list property in any file
  2. Place cursor within the property’s value input field
  3. Press hotkey for “Add internal link”

Did you follow the troubleshooting guide? [Y/N]


Expected result

I expect the hotkey should add the syntax for internal links.

Actual result

Nothing happens.


Obsidian version: v1.4.5
Installer version: v1.3.5
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 17
Plugins enabled: 16
1: Obsidian Git v2.17.0
2: Calendar v1.5.10
3: Style Settings v1.0.3
4: Various Complements v7.3.0
5: Export Image plugin v1.0.3
6: Dataview v0.5.55
7: Advanced Slides v1.20.0
8: Code Emitter v0.0.8
9: Auto Note Mover v1.2.0
10: Buttons v0.4.19
11: Text Generator v0.3.18
12: Webpage HTML Export v1.6.0
13: Kanban v1.5.3
14: Emoji Toolbar v0.4.1
15: Mindmap NextGen v1.9.0
16: Advanced Tables v0.19.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

On another note, I don’t like that I have to put internal links within quotation marks, or that tags are defined without hashtags, as shown here:

As it is now, I can’t edit link or tag properties conveniently in neither read-view nor edit-view. When I’m editing properties in read-view, I am forced to type the syntax for links manually. When I’m editing properties in the raw edit-view, obsidian hotkeys (“Add internal link”, “Add tag”) inserts strings that are incompatible (missing quotation marks and hashtags) with the provided format for properties.

“Properties” has a lot of potential, but should be semantically consistent with how links and tags have worked prior to it’s release.

1 Like

No editor command works (and will work) within the properties UI. The bug if anything is that it appears in the command palette as available.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.