Add a setting to disable rendering unclosed HTML tags like <div>

Use case or problem

Sometimes I’ll have markdown not rendered for any apparent reason, until I find an HTML tag like <div> without a </div> after it to close it, which I have to escape or put `s on.

Proposed solution

A setting to disable rendering unclosed HTML tags.