3 basic questions

I will try to answer the second one.

They fold according to their hierarchy. In markdown, the amount of ‘#’ symbols.

Say you have this:

After folding ‘Title’, only the lines with more ‘#’ symbols than ‘Title’ will fold

1 Like

Thanks, cristian.
In fact, I may have misspoken: regardless of the number of #, what I’m interested in is how to get out of folding without having to add a next #.

Do you mean you want to turn off fold heading?

That is interesting.

Perhaps he is asking how to stop something from being foldable. I actually think it would be pretty helpful as a feature. Maybe there could be a separate request to format permanently unfoldable content within a foldable list or heading structure. This would mean that content would fold before and after this permanently flagged region. As of now, I don’t believe it is possible.


I just would:

# item
This part of the text is folded / foldable in the header “item”.

Now, this part of the text is out of the previous “item” header, and therefore visible whatever the state of “item” (folded or unfolded).

But this may simply not be possible!

you could use this as a work around:
# 1st level (this one keep unfold)
## 2nd level heading (this one fold)
text text
## 2nd level (this one keep unfold)
text text

Thanks for the help, but i have to admit that i don’t understand your answer (!)
I come to the conclusion that there is unfortunately no solution to this headers “issue”!
it’s strange that we can’t do that, just get out of a header.
Thanks anyway.

Sorry, i edited it to make it more clear if you are still interested.
If that is still not what you want, you could create a feature request :smiley: .

Obsidian uses markdown, and markdown uses hierarchical # Headings to define a document’s structure.

So, there should only one # Title at the top, and all other headings under it are its children; ## First subsection marks a level 2 section; it’s a child of # Title and a parent to all the ### Headings immediately under it. A ## Second subsection may follow, with or without children. And so on.

As you can see, the only way to coherently fold Markdown sections is to observe the document’s structure — and that is based on the heading hierarchy.

If you don’t care much for Markdown document structure, Obsidian allows you to fold text according to tab-indentation:

Main topic
    Subtopic 1
        Item 1
        Item 2
    Subtopic 2
        Item 1
        Item 2

Here, you’re be able to fold at Main Topic, Subtopic 1 and Subtopic 2.

Hope this helps.

You can select some text, type (, and both () will be inserted around the selection.
As for typing, the only advantage I can think of is in those (rare?) occasions when you won’t type anything else after the closing ) or ". (Anyway, you’d always have to manually move out of the surrounding characters; how else would the editor know you were done?)

1 Like

As far as I know there’s no way to ‘escape’ the section that folds underneath a header without using another header - it goes against markdown spec but I have been using a second h1 further down the page, with no header text. In preview mode it looks/works fairly cleanly as a container for hiding stuff/separating stuff from being nested under the actual h1 title at the top.

There are several possible causes. If this is happening with the Daily Notes core plugin, submit a bug report, filling out the post template. If you’re using the Templates plugin, contact the developer. In any case, you’ll have to provide more information about your setup and how you’re trying to make it work.

1 Like

Ah! I had the same problem.

Daily notes works differently to the other plugins.
You have to specify a format inside.

My daily note template:

date created: :date: {{date:YYYY-MM-DD HH-MM}}

  • #journal/{{date:YYYY}}/{{date:MM}}’

Good catch. I never noticed that.

Given that the Daily Note plugin settings have a field called “Date format”, and having set it there, it’s only natural that one doesn’t think of specifying it again in the {{date}} tag. I think this could qualify as a bug.

1 Like

I really think it’s a bug, probably not that difficult to fix.

Thanks, but it doesn’t keep unfold, because it has # !

ok, thank you !

@macedotavares @cristian

For my date problem, here’s what’s going on:
I click on the daily note button, which uses a date format i defined in the preferences, and a template I created.
But the date remains as {{date}} in the body of the text.
I just wanted a simple template like this:

{{date}} (=first line of the note body)

##### THING

- - -
text out of ##### THING

I believe @cristian has addressed this in his reply.

1 Like

I had the same problem and tried what they typed above and it worked.

{{date:YYYY-MM-DD HH-MM}}

Not sure if it will do the same when you add (=first line of note body) but in mine it staid as the first line where I had it. Hope it helps.